Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Sortie de l'EDI Eclipse 3.3 - nom de code Europa

Le , par xavlours

42PARTAGES

0  0 
Bonjour,

Aujourd'hui est un grand jour : pour la seconde année consécutive, la fondation Eclipse propose un téléchargement packagé et une montée en version commune de plusieurs des projets basés sur la plateforme Eclipse.

Autour des 15h - heure française - vous devriez pouvoir accéder à cette nouvelle release (il risque d'y avoir du monde )

Pour suivre le décompte : http://www.eclipse.org/europa/

N'hésitez pas à partager vos premières impressions en réagissant à la suite.

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de Sebou77
Membre actif https://www.developpez.com
Le 29/06/2007 à 12:15
Parmis les projet mis à jour, serait il possible que chacun donne son avis sur ceux qu'il utilise et surtout leurs avantage.

Personellement j'en connais peu, et je trouve qu'il y en a beaucoup

* AJDT 1.5
* BIRT 2.2
* Buckminster 0.1.0
* CDT 4.0
* DLTK 1.0
* DSDP DD 0.9
* DSDP TM 2.0
* DTP 1.5
* ECF 1.0
* Eclipse Platform 3.3
* Dash 1.0
* EMF 2.3
* EMF-QTV 1.1
* M2T (JET) 0.8
* GEF 3.3
* GMF 2.0
* MDT 1.0
* Mylyn 2.0
* STP 0.6
* TPTP 4.4
* WTP 2.0
0  0 
Avatar de moritan
Membre expert https://www.developpez.com
Le 29/06/2007 à 15:07
Et voila Europa est officiellement disponible sur le site d'Eclipse
0  0 
Avatar de bizulk
Membre confirmé https://www.developpez.com
Le 30/06/2007 à 11:53
Bonjour,

Au travail j'utilise un PC avec Suse Linux 10.0 + JAVA 1.5 + Eclipse 3.2.2 (version GTK) + CDT 3.1.2 (pour rappel c'est un plugin pour dévélopper en C/C++). Je compte suivant la stabilité du tout, la compatibilité ascendante (récupération automatique des projets), et les évolutions de CDT migrer vers cette nouvelle mouture eclipse+. Par sécurité je le ferai chez moi sur une debian AMD64 ETCH + environnement bureau Gnome + java V?.

J'espère faire ça ce we. a+
0  0 
Avatar de djo.mos
Expert éminent https://www.developpez.com
Le 01/07/2007 à 17:30
Bonjour.
Je viens juste de survoler eclipse 3.3 Europa, et voici les premières constatations :
  • eclipse tourne dans un entièrement dans exe, plus d'exe + javaw
  • c'est très rapide : je ne suis pas sur si ça vient du fait que je viens juste de l'installer, mais eclipse m'a l'air plus performant que la 2.2
  • une nouvelle interface de gestion des taches : de nouvelles priorités, meilleure interface, fonction de recherche, etc.
  • Grosse nouveauté coté WTP : la prise en charge complète de JSF. J'ai surtout adoré l'éditeur graphique de faces-config.xml


Je compte aussi tester Dali pour la persistance de données et surtout la prise en charge de JPA.
0  0 
Avatar de leyee
Membre averti https://www.developpez.com
Le 02/07/2007 à 9:24
Je vois avec plaisir que le profiler tpt est inclut dans cette nouvelle mouture : fonctionne il avec des projets utilisant java 1.5 ou java 6 ? Jusqu'alors, je m'étais résolu à developper sous eclipse et profiler sous netbean quand le besoin s'en faisait ressentir
0  0 
Avatar de anykeyh
Membre confirmé https://www.developpez.com
Le 02/07/2007 à 12:57
La derniere mouture du CDT (4.0) est franchement puissante, autant je trouvais la 3.0 ininterressant (lui preferant Code::Blocks) notamment du fait des problemes avec le code-completion, autant maintenant le code completion se fait d'une façon exemplaire, avec prise en charge des templates tout ça

Parcontre gros soucis, au boulot cette derniere version ne fonctionne pas: j'ai un plantage (type segfault) au lancement de l'executable sans savoir pourquoi... Suis-je le seul?

Code : Sélectionner tout
1
2
3
4
5
6
7
8
9
10
11
---------------------------
Eclipse: eclipse.exe - Erreur d'application
---------------------------
L'instruction à "0x7c94426d" emploie l'adresse mémoire "0x00000000". La mémoire ne peut pas être "read".


Cliquez sur OK pour terminer le programme.
Cliquez sur Annuler pour déboguer le programme
---------------------------
OK   Annuler   
---------------------------
Edit: J'ai modifier le fichier ini pour le faire correspondre à celui d'eclipse 3.2:

-vmargs
-Xms32m
-Xmx512m

Et maintenant ça démarre niquel
0  0 
Avatar de zegreg
Membre du Club https://www.developpez.com
Le 03/07/2007 à 8:36
Vous n'avez pas de problèmes avec les fichiers XML? Chez moi il ne les prend plus en compte ... Faudrait-il un plugin pour ça ?
0  0 
Avatar de Gougou
Membre à l'essai https://www.developpez.com
Le 03/07/2007 à 9:09
Citation Envoyé par Sebou77
Parmis les projet mis à jour, serait il possible que chacun donne son avis sur ceux qu'il utilise et surtout leurs avantage.

[snip]

Pour ma part j'utilise pas mal les frameworks modélisation :
EMF, GMF et un peu MDT (surtout la partie UML2).

Les avantages de EMF sont nombreux, assez simple à prendre en mains, très efficace et très bien conçu. Pour GMF l'avantage est la rapidité à mettre au point un prototype de modeleur graphique quand on a bien en main le framework. Par contre l'architecture est assez complexe et la prise en main n'est pas des plus simple. Enfin pour UML2 l'avantage est son côté standard et que de plus en plus de modeleurs s'en rapprochent.

J'ai également utilisé à un moment Mylar et j'étais assez convaincu mais il a fallut que je passe en java 1.4 et donc de l'abandonner un moment. Pour le peu que j'ai vu sur Europa ça a l'air pas mal.

Enfin c'est pareil j'avais testé ECF et j'avais été pas mal bluffé par la simplicité des outils.

Et voila
0  0 
Avatar de Javix
Membre averti https://www.developpez.com
Le 12/07/2007 à 14:55
C'est pas mal. Mais j'ai découvert une chose bizarre avant de faire un projet-test WEB. L'installation de Tomcat 6.0 s'est bien passée. Je peux lancer et stopper le serveur. Par contre, pas moyen d'accéder à la page d'acceuil de Tomcat (http://localhost:8080) via le brouser d'Eclipse Europa. Tojours Error 404. Et si le serveur est démarré sous Eclipse, dans Mozilla ça fonctionne. Bizarre, non? Quelquna déjà eu le même pb ?
0  0 
Avatar de Spoutnik
Membre éclairé https://www.developpez.com
Le 18/07/2007 à 11:12
Hello,

Je viens de passer sur le site ... grosse surprise ... il semble ne pas y avoir de version linux 64bits ...

C'est moi qui sais plus lire? ou bien eclipse oublie les linuxiens sous 64b ?

[Edit] je viens de tomber sur un post de la newsgroup voici le lien de la page de téléchargement : http://download.eclipse.org/eclipse/...1500/index.php[/Edit]
0  0