support  EDI  version