support  version  EDI